0
$\begingroup$

we are having trouble starting our PC12. After introducing fuel at stabilized 13% ng, the engine spools up very slowly - it takes forever to get through 20, 30, 40%ng. We've had several hung starts, and aborted starts. Battery discharge test is fine - 106% on the first test, and it is a new battery. Any suggestions for next step trouble shooting? Our mechanic doesn't seem to have a clue.

$\endgroup$
  • 2
    $\begingroup$ Our mechanic doesn't seem to have a clue. - Get a better mechanic. $\endgroup$ – Jamiec Apr 24 at 13:46
7
$\begingroup$

Either the starter generator isn't making the torque it should be making, or there is a fuel flow issue. If I was betting 10 bucks on the result, I'd go with weak starter/generator and swap it out if another was available, or do diagnostic testing on the unit like insulation resistance checks and other electrical tests on the motor.

Regardless, if your mechanic is not sure how to proceed he/she should be on the phone to Pratt & Whitney Canada tech support or going through the PWC online portal to access the Fault Isolation Manual for that engine and just follow the steps.

If you're a pilot standing by watching the action, you'll really piss off the mechanic by relaying him troubleshooting instructions from some anonymous nobody from ASE, so I would only intervene if the mech was hiding in the bathroom and refusing to come out.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.